my blog lives here now
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

27 lines
542 B

{ pkgs ? import <nixpkgs> { }, stdenv ? pkgs.stdenv }:
let
site = pkgs.haskellPackages.callCabal2nix "blag-site" ./. { };
our-texlive = with pkgs; texlive.combine {
inherit (texlive)
collection-basic
collection-latex
xcolor
preview
pgf tikz-cd
mathpazo
varwidth xkeyval standalone
jknapltx;
};
in
stdenv.mkDerivation {
name = "blag";
src = ./.;
buildInputs = with pkgs; [
poppler_utils
rubber
nodePackages.katex
our-texlive
site
];
}